Vulnerabilities and security researches formapster-wp-maps mapster-wp-maps
Direction: ascendingJun 07, 2024
Mapster WP Maps # 19e7ea1e09f3af5b92d8a112012b7c6a59ada0d1
- CVE, Research URL
- Home page URL
- Application
- Date
- Jul 18, 2023
- Research Description
- Mapster WP Maps [mapster-wp-maps] < 1.2.36 WordPress Mapster WP Maps Plugin < 1.2.36 is vulnerable to Cross Site Scripting (XSS) Update the plugin to the latest version. Rafie Muhammad (Patchstack) discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress Mapster WP Maps Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 1.2.36.
- Affected versions
-
max 1.2.36.
- Status
-
vulnerable
Mapster WP Maps # CVE-2024-21744
- CVE, Research URL
- Home page URL
- Application
- Date
- Jan 08, 2024
- Research Description
- Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mapster Technology Inc. Mapster WP Maps allows Stored XSS.This issue affects Mapster WP Maps: from n/a through 1.2.38.
- Affected versions
-
max 1.2.39.
- Status
-
vulnerable
Oct 26, 2024
Mapster WP Maps # CVE-2024-9235
- CVE, Research URL
- Home page URL
- Application
- Date
- Oct 25, 2024
- Research Description
- The Mapster WP Maps plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to an insufficient capability check on the mapster_wp_maps_set_option_from_js() function in all versions up to, and including, 1.5.0. This makes it possible for authenticated attackers, with contributor-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.
- Affected versions
-
max 1.6.0.
- Status
-
vulnerable
Nov 17, 2024
Mapster WP Maps # CVE-2024-10592
- CVE, Research URL
- Home page URL
- Application
- Date
- Nov 16, 2024
- Research Description
- The Mapster WP Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the popup class parameter in all versions up to, and including, 1.6.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Affected versions
-
max 1.7.0.
- Status
-
vulnerable
Oct 12, 2025
Mapster WP Maps # CVE-2025-9044
- CVE, Research URL
- Home page URL
- Application
- Date
- Sep 26, 2025
- Research Description
- The Mapster WP Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple fields in versions up to, and including, 1.20.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with contributor-level permissions and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Affected versions
-
max 1.21.0.
- Status
-
vulnerable
May 02, 2026
Mapster WP Maps # CVE-2024-13362
- CVE, Research URL
- Home page URL
- Application
- Date
- May 01, 2026
- Research Description
- Multiple plugins and/or themes for WordPress are vulnerable to Reflected Cross-Site Scripting via the url parameter in various versions due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
- Affected versions
-
max 1.21.0.
- Status
-
vulnerable
Aug 04, 2026
Mapster WP Maps # CVE-2026-14839
- CVE, Research URL
- Home page URL
- Application
- Date
- Aug 01, 2026
- Research Description
- The Mapster WP Maps WordPress plugin before 1.24.0 does not perform any authorization or post-status check on a public REST endpoint, allowing unauthenticated users to retrieve the title and full content of any post regardless of its status, including unpublished (draft, pending, private, and trashed) posts.
- Affected versions
-
max 1.24.0.
- Status
-
vulnerable
Sep 19, 2026
Mapster WP Maps # CVE-2026-12954
- CVE, Research URL
- Home page URL
- Application
- Date
- Sep 18, 2026
- Research Description
- The Mapster WP Maps plugin for WordPress is vulnerable to Arbitrary User Meta Write in all versions up to, and including, 1.23.0 via the `my_profile_update()` function. This is due to the function performing no nonce verification, no capability check, and no allowlist validation on the meta key supplied via the `acf-photo-gallery-groups` POST parameter before passing both the meta key and its corresponding value directly to `update_user_meta()`. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary user meta values, though privilege escalation is not possible.
- Affected versions
-
max 1.24.0.
- Status
-
vulnerable
Oct 08, 2026
Mapster WP Maps # CVE-2026-39720
- CVE, Research URL
- Home page URL
- Application
- Date
- Oct 06, 2026
- Research Description
- Unauthenticated Cross Site Scripting (XSS) in Mapster WP Maps <= 2.0.4 versions.
- Affected versions
-
max 2.0.4.
- Status
-
vulnerable
Oct 30, 2026
Mapster WP Maps # CVE-2026-107743
- CVE, Research URL
- Home page URL
- Application
- Date
- Oct 29, 2026
- Research Description
- The Mapster WP Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.0.5. This is due to the /wp-json/mapster-wp-maps/save-mapmaker REST route being registered with a permission_callback that unconditionally returns true (no capability check, no nonce), together with the mapster_write_config_to_acf() helper only sanitizing string config values with sanitize_text_field() — which strips HTML tags but leaves quote characters intact — and the mapster_wp_map shortcode renderer in mapster_wordpress_maps_shortcode_display() concatenating the stored loading_background_color value into a single-quoted inline style attribute without esc_attr(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Affected versions
-
max 2.0.6.
- Status
-
vulnerable
Nov 03, 2026
Mapster WP Maps # CVE-2026-118638
- CVE, Research URL
- Home page URL
- Application
- Date
- Oct 31, 2026
- Research Description
- The Mapster WP Maps WordPress plugin before 2.0.6 does not perform any authorization check on a REST API route that writes post data, allowing unauthenticated attackers to overwrite the title of arbitrary posts, create arbitrary published posts, and overwrite the Mapster WP Maps WordPress plugin before 2.0.6's stored settings.
- Affected versions
-
max 2.0.6.
- Status
-
vulnerable